0: CURL_LOGIN_FAILURE on Joomla Homepage

Support specific to the Moodle plugin (http://moodle.org/).

Moderator: hwevers

Forum rules
Please post all the bugs you encounter on our issue tracker.

0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby pavankks on Sun Jan 02, 2011 3:46 pm

1. Have you searched the forums and checked the documentation section for a solution?
Yes, for the last three days now. Good to see all the support you have been providing to users.

2. Please summarize your problem in a few lines.
Joomla Website: http://www.lassib.org/
Moodle Website: http://www.lassib.org/learn/

We imported over 1600 users from a Moodle installation into Joomla some time back. Joomla is Master and Moodle is Slave.

Any new users registered on Joomla are able to login, are synchronized with Moodle and when they open Moodle they are automatically logged into Moodle. These users can also directly log into Moodle site.

When any of the 1600 imported users login to Joomla, we need the following error. "0: CURL_LOGIN_FAILURE" on homepage. These users also cannot log into Moodle directly.

3. What steps will reproduce the problem?
Log into Joomla with the login id of any of these 1600 imported users and we see the error: "0: CURL_LOGIN_FAILURE"

Log into Joomla with a new user registration and everything is fine.

4. What is the expected output? What do you see instead?

When we log into Joomla with the login id of any of these 1600 imported users everything goes fine.

5. You must include a printout of the login checker in the JFusion component.
Server Configuration
Joomla Version 1.5.22
PHP Version 5.2.14
MySQL Version 5.0.91-log
System Information Linux p3nlh044.shr.prod.phx3.secureserver.net 2.6.18-194.26.1.el5PAE #1 SMP Tue Nov 9 13:34:42 EST 2010 i686
Browser Information Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
jfusion user Plugin Enabled
jfusion authentication Plugin Enabled

JFusion Versions
JFusion Component Version 1.5.4-000 (Rev 2415)
JFusion Authentication Plugin Version 1.5.4-000
JFusion User Plugin Version 1.5.4-000
JFusion Activity Module Version 1.5.4-000
JFusion Login Module Version 1.5.4-000
JFusion Search Plugin Version 1.5.4-000
JFusion Discussion Plugin Version 1.5.4-000

JFusion joomla_int Plugin
configuration master 1
slave 0
dual_login 1
check_encryption 1
JFusion moodle Plugin
configuration master 0
slave 1
dual_login 1
check_encryption 1


Authentication Plugin
userid 1020
activation ""
username ruma
name Ruma *******
password 2e627f********
email br***@h**.com
block 0
group_name Registered
group_id 18
params language= timezone=5.5
password_salt 9sni*****
language en-GB
credentialed_username ru****
password_clear ******
Authentication Plugin Success
Authentication Plugin Debug
0 joomla_int Password Encryption Check: 2e627f******** vs 2e627f********
1 joomla_int Password Encryption Check: Success

jfusion User Plugin
User Plugin Success
User Plugin Debug
init 0 Using userinfo JFusion authentication plugin
joomlaid 1020
moodle User Update 0 A user has been found that matches the login details
1 Skipped Password Update:Password already valid
2 updateUsergroup function not implemented
3 Language of the user not updated

Code: Select all
Enter your login checker output here.

oodle User Details id 981
auth email
confirmed 1
policyagreed 1
deleted 0
mnethostid 1
username ru**&**ma
password 33a241********
idnumber ""
firstname Ruma
lastname Cha******
email br88@*****.com
emailstop 0
icq ""
skype ""
yahoo ""
aim ""
msn ""
phone1 ""
phone2 ""
institution ""
department ""
address ""
city Faridabad
country IN
lang en_us_utf8
theme ""
timezone 99
firstaccess 1263111522
lastaccess 1293932509
lastlogin 1276408567
currentlogin 1293932507
lastip 14.96.209.139
secret ""
picture 0
url ""
description
mailformat 1
maildigest 0
maildisplay 2
htmleditor 1
ajax 1
autosubscribe 1
trackforums 0
timemodified 1263385583
trustbitmask 0
imagealt ""
screenreader 0
userid 981
name R******* ********
activation false
block false
registerDate 10-01-2010 01:18:42
lastvisitDate 12-06-2010 22:56:07
password_clear ******
moodle Session 0 Trying to find loginform using url: http://www.lassib.org/learn/login/
1 Login page read, setting cookies first phase:
2 Valid login form found
3 Valid username and password fields found
4 Starting login: action= http://www.lassib.org/learn/login/index.php parameters= username=ru**ma&password=xxxxxx&login[indirect]=no&submit=login&jnodeid=www.lassib.org
5 Login performed, setting cookies definite phase:
6 Type of remote login used by cURL=standard
User avatar
pavankks
JFusion Newbie
JFusion Newbie
 
Posts: 6
Joined: Sun Jan 02, 2011 3:19 pm

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby pavankks on Sun Jan 02, 2011 5:20 pm

I made one additional test, as recommended in other posts.

Changed the Master to Moodle, and Salve as Joomla. Disabled registration at Joomla and enabled registration at Moodle.

Now the 1600 users ported can login to Moodle. The users who directly registered at Joomla earlier are able to login as well.

So the problem occurs only when Joomla is Master and Moodle is Slave, and when those 1600 users ported try and login.

Hope this narrows down the problem.
User avatar
pavankks
JFusion Newbie
JFusion Newbie
 
Posts: 6
Joined: Sun Jan 02, 2011 3:19 pm

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby pavankks on Sun Jan 02, 2011 5:59 pm

By the way i also have the JFusion and Community Builder plugin also installed - if that is of any help.
User avatar
pavankks
JFusion Newbie
JFusion Newbie
 
Posts: 6
Joined: Sun Jan 02, 2011 3:19 pm

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby hwevers on Thu Jan 06, 2011 3:15 pm

Try removing CB and see if that helps.
If so I have no cure at the moment.
Henk
User avatar
hwevers
Developer
Developer
 
Posts: 870
Joined: Fri May 02, 2008 10:06 am
Location: The netherlands

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby pavankks on Mon Jan 10, 2011 11:07 pm

Hi,

I removed CB and made my login on homepage to the JFusion Login Module.

But it is the same issue.

Any ideas?

Best regards,
Pavan Kota
User avatar
pavankks
JFusion Newbie
JFusion Newbie
 
Posts: 6
Joined: Sun Jan 02, 2011 3:19 pm

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby hwevers on Wed Jan 12, 2011 3:35 am

Can you for a test, delete one of the ported users in Moodle (and remember the credentials).
Then set Joomla as master and Moodle as slave. Now try login this user (using the loginchecker).
Then show me the results please.
Henk
User avatar
hwevers
Developer
Developer
 
Posts: 870
Joined: Fri May 02, 2008 10:06 am
Location: The netherlands

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby pavankks on Fri Jan 28, 2011 4:33 pm

Ok, I finally got this resolved. The following is what I did.

1) Deleted all users of moodle other than the administrative user
2) Synchronized the users once again fro Joomle as Master into the Moddle as Slave

And then the everything worked well thereafter.

Thanks to the Jfusion team for all the help. It provided vital clues.

Please keep up the good work.

Best regards,
Pavan Kota
User avatar
pavankks
JFusion Newbie
JFusion Newbie
 
Posts: 6
Joined: Sun Jan 02, 2011 3:19 pm

Re: 0: CURL_LOGIN_FAILURE on Joomla Homepage

Postby pavankks on Fri Jan 28, 2011 4:34 pm

Thanks hwevers.

Appreciate all the help.

Best regards,
Pavan Kota
User avatar
pavankks
JFusion Newbie
JFusion Newbie
 
Posts: 6
Joined: Sun Jan 02, 2011 3:19 pm


Return to Moodle

Who is online

Users browsing this forum: No registered users and 2 guests